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1. Configurando MPI para C/C++

1.1 Paquetes a instalar

Puede usar el gestor de paquetes Synaptic para instalar los siguientes paquetes:

> binutils
Archivo Editar Paguete Configuracion Ayuda
» automake — _ s
=) 57} .
> aUtOCOHf Recargar Marcar todas las actualizaciones Aplicar Propiedades | Buscar
> g++ Todo [ E B Paguete :Versi()n instalada | Ultima version |Descripcion ‘,‘
> gcc _ O mpich-mpd-bin 1.2.7-8 MPI parallel computing sy
> 4 1 mpichpython 2.4.11-lubuntu?  MPl-enhanced Python inte
m [ - . . =0
> Iibtool [0 mpi-doc 1.2.7-8
[T ) I
> kon SOIe \l\ ;;‘{MPI parallel computing system implementation, SHMEM version
> kd evelop Secciones | |MPICH is a robust and flexible implementation of the MPI (Message Passing
= Interface). MPIis often used with parallel or distributed computing
. . stado
> mplch-sh mem-b|n = projects, MPICH is & multi-platform, configurable system (development,
. . Origen execution, libraries, etc) for MPI, [t can achieve parallelism using
> IIbmpICh_Shmem 1'0_ Filtros personalizados networked machines or using multitasking en a single machine. “’
dev \

Resultados de bosqueda

ITh & rananilad with ch ek et _iuhish harad

libmpich-shmem1.0gf 38 paauetes listados, 1235 instalad

Y

0 para instalar/actuzlizar, 0 para eliminar

1.2 Creando un programa en Kdevelop

Menu Project -> New Project. Elegir proyecto de C/C++ y escribir el nombre del proyecto a creary
elegir la ubicacién del mismo.

General
All Projects | Eavorites
@ [E3c
] [ERE2)
[_] Show all project templates
Application name: |MiPmyE(tu ]
Location: |/nomejmanuel/Proyectos/ | (]
Final location: /home/manuel/Proyectos/MiProyecto
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En el menu Project -> Project Options -> Configure options, en la pestafia C, debe configurar las
siguientes opciones:

Compiler: GNU C Compiler

Compiler Command (CC):  /usr/lib/mpich-shmem/bin/mpiCC
Compiler Flags (CFLAGS): -00-g3

‘.(.] |~| <Configure Options

—a
General

Configuration: [debug | i ‘

‘f:i General Ic_l C++ |Ecxrtmn |

Version Control € compiler: | enu € compiter [=]

File Templates Compiler command (CC): !;‘usrfliblmpi(h—shmsmjbln/mpicc |

| S
N L P ~ Compiler flags (CFLAGS): |700 -g3 | | ]
Project Documentation !
=Y
S
File List
I g
C++ Support

)

Run O#hns

Y

Make Options
5 )
8

Farm‘atting %

OK || Cancel

En el mend Run Options, debe escribir la siguiente informacidn:

Executable: Jusr/lib/mpich-shmem/bin/mpirun
Run Arguments: -np noDenodos rutaDondeSeGeneraElEjecutableDeTuProyecto
Working Directory: rutaDeTuProyecto

<] Run Options
General ~ % Main Program
SN Note: These options override target specific settings.
Version Control Executable: | rasestibim pich-shmemybin/mpirun I=
Run Arguments:  |-np 2 fhome/manuel/Proyectos/Fox/debugfsrc/fox |
File Templates Debug Arguments: | |
| _‘ Working Directory: |fhumefmanueI,leyectus/FacturEal ||B“
R o
Project Documentation o
Q [T Automatically compile before execution
e
File List ] Automatically install before execution
[_J [] Use kdesu when installing
it
C++ Support [®| Start in external terminal
‘QFJ - Environment Variables
Configure Options Name - Value ‘ Add | Copy ‘
S) ————
Run Options ‘ Remove ‘
|3-“ ‘ Environment ‘
Make Options —_—
fa}
s l
Formatting I"

OK I Cancel

Posteriormente aceptar los cambios dando click en OK.
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Escribir tu programa, pero no olvides incluir la libreria mpi.h. A continuacién se muestra un cédigo de
ejemplo.

factorial.c |

#ifdef HAVE CONFIG H

#include =config.h>

#endif

#include "fusr/lib/mpich-shmem/include/mpi.h"
#include <stdio.h=>

int main({int argc, char *argvll)

H1{
2 int nodos,rango;
MPI_Init(&argc,&argv);
MPI_Comm_rank{MPI_COMM_WORLD,&rango);
MPI_Comm_size(MPI_COMM WORLD,&nodos);
printf({"Hola mundo desde el nodeo %d\n",rango);
MPI_Finalizel();
return ©;
LA

Antes de compilar por primera vez, debes dar click en las siguientes opciones:
Mendu Build -> Install
Menu Build -> Run Automake & Friends
Menu Build -> Run Configure

Para compilar se da click en Menu Build -> Build Project y posteriormente en Menu Build -> Build
Active Target.

Para ejecutar tu programa click en Menu Build -> Execute Program

Eile Edit ¥View Project [Byj!d Debug Scripts Bookmarks Tools Settings Window Help

— + |[Z] Build Project Fa | @ r T

;] N S & =1 Build Active Target F7 [ E E Q
IBE 38 & E| compilesle

| Run Configure

|]\Iame | an(‘
® EHeaderﬁles Run automake & friends Foao:
@ [E§Source files Iustall
Install {as root user) numero del cual quieres
Clean Project
Distclean o
bsaclor
[NT,1,tag,MPT_COMM WORLD)
%) Execute Program Shift+Fg3

Build AP| Documentation 1

Clean API Documentation

printf("El factorial de %d es <%d",num,resul

s .y Bookmarks %4 File List |54 File Selector

. . MPI Recv(&resultado2,1,MPI_INT,1,MPLI ANY TAG,
}

EY

Después de ejecutar tu programa debe aparecer una pantalla como la siguiente:
Session Edit Wiew Bookmarks Settings Help

Hola munde desde el nodo 1 -
Hola mundo desde el nodo @
Press Enter to continue!

=] | pinsh
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2. Configurando openMP para C/C++

2.1 Paquetes a instalar

Debe instalar los siguientes paquetes, sélo si no instalé los necesarios para usar MPI.

Archivo Editar Paquste Configuracién Ayuda

> binutils : & | .
Recargar Marcar todas las actualizaciones Aplicar | Propiedades | Buscar
> aUtomake iTndn 7| ?‘ 7| Paquete |Versién instalada i Ultima versisn iDescripcm’n =
> autoconf [ mpich-mpd-bin 1.2.7-8 MPI parallel computing s
> ++ =] mpichpython 2.411-lubuntuz  MPl-enhanced Python inte|
& gy ich shmemebin . P peraliel campiting =]l
> gCC 1| 1.2.7-8 Documentation for the MI_|
[ I v
> m4 - = arar ~ 7 e S B e F |
[T | [+ |MPI parallel computing system implementation, SHMEM version =
> I|bt00| Secciones [ MPICH is & robust and flexible implementation of the MPI (Message Passing
Interface). MPIis often used with parallel or distributed computing
» konsole Estedo | ——_— :
" |prejects. MPICH is a multi-platform, configurable system (development,
> kd evelop Origen l execution, libraries, etc) for MPI, It can achieve parallelism using
Filtros personalizados | | metworked machines or using multitasking an a single machine. il
‘ Besultados de bisqueda o ol it ek ke s ik ey bl =

38 paquetes listados, 1285 instalados, 0 rotos, 0 para

instalar/actualizar, 0 para eliminar

2.2 Creando un programa en Kdevelop
Menu Project -> New Project. Elegir tipo de proyecto C/

y escribir el nombre del proyecto a crear y elegir la
ubicacién del mismo.

Elegir la opcidn default del menu

General

C++ All Projects | Favorites |
El=I=

7 (— 7 — [=12)
(] show all project templates

 Propertis
Application name: [MiProyecto |
Location: | neme/manuelProyectos/ ] |E]
Final location: /home/manuel/Proyectos/MiProyecto

|| cancel |

Build Debug Scripts Bookmarks Tools Sett

Project-> Build Configuration ] New
= Open
Open

Y Impo

Build

&‘ MNew Class...

Distribution & Publishing
4, Project Options
€3 Close Project |

KOERGE
L[

Project... B
Project... e
Recent Project L
rt Existing Project...

=

Configuration

debug

optimized

i

I wandi f
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Para configurar openMP, debe dar click en Menu Project -> Project Options -> Configure Options, y en
la pestafia general debe configurar la siguiente opcidén:

Linker Flags (LDFLAGS): -fopenmp

|~| configure Options

Eer;:al Configuration: |debug tl I |

[General | € [ Srr [ o |

S
Version Control GolFige eunent:
[--enab!e-debug:full ]
File Templates Build directory {must be different for every different configuration):

e [Gebug =

Top source directory:

Project Documentation

b [ =]
File List CIC[»+ preprocessor flags (CPPFLAGS): ‘

Linker flags (LDFLAGS):

C++ Support

[-fupenmp ]
E Environment Variables
Configure Options ” Name - Value | | Add / Copy J

C_ex |
Run Dfions IT{:!E

Make Options
&

- A

Formatting H

ok || cancel

Y en la pestaia C, debe configurar la siguiente opcion

C Compiler: GNU C Compiler
Compiler Flags (CFLAGS): -pg -fopenmp

V)

Configure Options

a s i

Gandral Configuration: ldefau!t |*|
_@ General |C | c++ | Fortran |
Version Control C compiler: lGNU C Compiler ‘ VI
File Templates Compiler command {CC): [ |
ol
L_F Compiler flags (CFLAGS): [—pg -fopenmp I |:]

Project Documentation
a
File Li

S

L

C++ Support

Configure Options

E)

Run Options

£l

Make Options

2

Formatting

ok || cancel
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Elegir el menu

Make Options

y establecer a las variables

WANT_AUTOMAKE_1 6 los valores de 0.

Iv]

a
]
General

2
Varsiorll Control
File Templates

-

L5
Project Documentation
@

)

File List

C++ Support
1

Configure Options

Run Opjtio ns
B
L4
Make Options

‘a

S

Make Options

Tec. Manuel Antonio Ortiz Montalvo
WANT_AUTOCONF 2 5

Formatting

% Abort on first error

"] only display commands without actually executing them

-
-

Make priority: [0

[ Run more than one job at a time

MName of make executable: l

~ Environment Variables

Add /copy |

Name Value |
WANT_AUTOCONF 2_5 0 |

WANT_AUTOMAKE 1_6 a

Environment ’

Edit |

Remove |

Posteriormente aceptar los cambios dando click en OK.

Escribir el siguiente codigo de ejemplo, para demostrar como funciona openMP. Nétese que debe
incluir la libreria omp.h, como se muestra en la siguiente figura.

pruebaomp.c I

#ifdef HAVE CONFIG H
#include <config.h=
#endif

#include <stdio.h>
#include =stdlib.h>
#include <=omp.h=

int main(int argc, char *argv[])

=1 . int noHilo,tetalHilos:
omp_set num threads(4);
8 #pragma omp parallel privatelnoHilo) shared(totalHiles)
[ f totalHilos=omp_get num_threads();.
noHileo=omp_get thread num();
. printf("Thread= %d de %d\n",noHile,totalHilos);
| ¥
#pragma omp end parallel
o return EXIT SUCCESS;
B3
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Antes de compilar por primera vez, debes dar click en las siguientes opciones:
Menu Build -> Install
Menu Build -> Run Automake & Friends
Menu Build -> Run Configure

Para compilar se da click en Menu Build -> Build Project y posteriormente en Menu Build -> Build
Active Target.

Para ejecutar tu programa click en Menu Build -> Execute Program

Eile Edit Miew Project EJJ?J Debug Scripts Bookmarks Tools Settings Window Help
T I 21 Build Project Fg - T r
= B ) | o | |
; et v d ] Build Active Target F7 ‘%‘ ¥ :E ;E m v
IB B O 9 & E| compilerie
§ |Name | Lcc;'l Run Configure
=] —— . . i
% ® |23 Header files Run automake & friends —
Y @ [EFsource files nstall
% Install (as root user) numero del cual guieres
ﬂ Clean Project
+ Distclean | Do —
» [NT,1,tag,MPT COMM WORLD)
= ¥ Execute Program shift+F9
Build APl Documentation F+)
E Clean APl Documentation
m
B
'§ MPI_Recv(&resultado2,1,MPI_INT,1,MPI_ANY TAG,
m
34 . printf("El factorial de %=d es %d",num,resul
wi }
i

Después de ejecutar tu programa debe aparecer una pantalla como la siguiente:

Session Edit View Bookmarks Settings Help

manuel@manuel-laptop:~/Proyectos,/PruebalMP/srcs ./pruebaomp E
Thread= 1 de 4
Thread= 2 de 4
Thread= 3 de 4 |__|
Thread= @ de 4 =
manuel@manuel-Tlaptop:~/Proyectos/PruebadMP/srcs I =

=] | = shell T
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2.3 Compilando y ejecutando desde la linea de comandos

Para compilar desde la linea de comandos, primero debes ubicarte en la carpeta que contiene el
codigo fuente.

Session Edit View Bookmarks Settings Help

manuel@manuel-laptop:~/Proyectos/PruebalMP/srcs cd =
manuel@manuel-laptop:~% cd Proyectos/PruebalDMP/src/
manuel@manuel - laptop:~/Proyectos/PruebalMP/src$ I

)] shenl |

Posteriormente ejecutar el siguiente comando para realizar la compilacién
gcc -pg -fopenmp -o programakEjecutable codigoFuente.c

Dénde:
-pg Activa la opcion de generar el Profile
-fopenmp Activa la opcion de crear ambiente paralelo
-0 Genera el archivo objeto
programakEjecutable Nombre del archivo ejecutable, que generard la compilacion
codigoFuente.c Nombre de tu archivo fuente

A continuacion se muestra un ejemplo:

Session Edit Wiew Bookmarks Settings Help

manuel@manuel-lapteop:~/Proyectos/PrucbalMP/src8 gcc -pg -fopenmp -o p |4
ruebaomp pruebaomp.c
manuel@manuel-laptop:~/Proyectos/PrucbalMP/srcs l

E,| = shell |

Y ya para ejecutar tu programa, sdlo debes escribir el nombre de tu ejecutable que se acaba de
generar, antecedido por los signos “./ “, vy tu programa debe empezar a ejecutarse, como muestra el

siguiente ejemplo:

10
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Session Edit View Bookmarks GSettings Help

manuel@manuel-laptop:~/Proyectos,/PruebalMP/srcS ./pruebaomp -
Thread= 1 de 4
Thread= 2 de 4
Thread= 3 de 4
Thread= 0 de 4 [
manuel@manuel -laptop:~/Proyectos/PruebalMP/srcs I

[]

5| W shell

11
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3. Creando el profile para C/C++

Si se desea hacer un analisis de la ejecucidn del cddigo, los tiempos que demoré la ejecucidn de cada
método, y las veces que se llamo cada uno, entre mucha otra informacidn, se puede crear el profile.

Para crearlo, primeramente el programa se tiene que compilar activando la bandera pg:

gcc -pg -openmp -o programa archivoFuente.f

Session Edit View Bookmarks Settings Help

manuel@manuel-laptop:~/Proyectos/ompConC/srcé gcc -pg -fopenmp -o prueba ompconc.c [
manuel@manuel-laptop:~/Proyectos/ompConC/src$ I

i;§§| i shell

Si compild correctamente, se tuvo que generar un archivo llamado gmon.out en la carpeta de tu
codigo fuente.

Posteriormente, se crea tu archivo profile, de la siguiente manera:
gprof programa gmon.out > archivo.txt

Donde:
programa:  Es el nombre del ejecutable que se generd durante la compilacion
gmon.out Archivo que se generd durante la compilacion con la bandera pg

archivo.txt ~ Nombre del archivo que generard con la informacion del profile

Session  Edit View Bookmarks Settings Help

manuel@manuel-laptop:~/Proyectos/ompConC/srcS gprof prueba gmon.out = profile.txt [+
manuel@manuel-laptop:~/Proyectos/ompConC/srcs I

Para visualizar el archivo que generd, sdlo tienes que escribir el comando:
edit nombreArchivo

Donde:

nombreArchivo: Es el nombre del archivo a visualizar, que es el que generamos con el
comando gprof

12
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A continuacidn se muestra un ejemplo de la ejecucidn del comando, y el resultado del mismo.

Session Edit View Bookmarks Settings Help

manuel@manuel-laptop:~/Proyectos/omplonC/srcs edit prc‘File.txtI |*i

B
=

2|

Session Edit View Bookmarks Settings Help

lat prefile: [

Each sample counts as 0.01 seconds.
no time accumulated

% cumulative self self total
time saconds saconds calls Ts/call Ts/call name
.88 2.06 .86 1 B.08 g.08 MAIN
% the percentage of the total rumning time of the
time program wsed by this function.

cumulative a running sum of the number of seconds accounted
seconds  for by this fumction and those listed above it.

self the number of seconds accounted for by this

seconds function alepe. This is the major sert for this
listing.

calls the number of times this function was invoked, if

this function is profiled, else blank.

self the awerage number of milliseconds spent in this
ms/call function per call, if this function 1is profiled,
else blank.
total the average number of milliseconds spent in this
ms/call function and its descendents per call, if this

]

[ﬁ\ ) Shell No. 3
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4. Configurando MPI para Fortran

4.1 Paquetes a instalar

Puede usar el gestor de paquetes Synaptic para instalar los siguientes paquetes:

Tec. Manuel Antonio Ortiz Montalvo

ma [ |G ——
|0 mpichpython

1.27-8

binutils
Archivo Editar Paguete Configuracion Ayuda
automake S LR SR S e Ve -
. & =5 R .
aUtOCOHf Recargar Marcar todss las actualizaciones  Aplicar | Propiedades | Buscar
gfortran jTudu [ ]E\‘ Paguete ‘Verswc'm instalada | Ultima versién |Descripeion
b L ez —

MPI parallel computing sy’
MPl-enhariced Python inte

i

v

VVVVVYVVVYVYVVYY

‘ Resultados de busqueda = I W N

libtool | mochshmenbin Pl parallel compating s
konsole || mpi-doc 1.2.7-8 Documentation for the
kdEVE|0p [ 1 [*/'MPI parallel computing system implementation, SHMEM version
mpich_shmem_bin Secciones MPICH is a robust and flexible implementation of the MPI (Message Passing
= | [Interface). MPIis often used with parallel or distributed computing
. . stado
- - = rojects. MPICH is a multi-platform; configurable system (development,

. proj p g Y p
. . Origen | |execution, libraries, etc) for MPI. It can achieve parallelism using
IIbmpICh_Sh meml'ogf Filtros personalizados | |networked machines or using multitasking on a single machine.

38 paquetes listados, 1205 nstalados. 0 rotos. 0 para instalar/actualizar, 0 para eliminar

[41

4.2 Creando un programa en Kdevelop

Menu Project -> New Project. Elegir proyecto de Fortran y escribir el nombre del proyecto a creary

elegir la ubicacion del mismo.

General

All Projects | Favorites

® [EFFortran

11 ENEY

] Show all project templates

— Properties

Application name: ImiPmyect0|

Location: lfhome!manuellProy ectos/

|l

Final location: fhomej/manuel/Proyectos/miProyecto

| Cancel |

14
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En el menu Project -> Project Options -> Configure options, en la pestafia Fortran, debe configurar
las siguientes opciones:

Compiler: GNU Fortran Compiler
Compiler Command (F77):  /usr/lib/mpich-shmem/bin/mpif77
|| Configure Options
Ge:?:l:a! Configuration; IF:
=Y [General | C [Cr+ | Fortran |

SR
Version Control Fortran compiler: [GNU Fortran 77 Compiler "l
File Templates Compiler command (F77): [Iusrflibfmpich—shmemlbin,fmpif?? |

5 L | Compiler flags (FFLAGS): ‘ | ‘ 1
Project Documentation e

£

File List
£}
S
Ftnchek
S
Configure Options
Run Oﬁions

Make Options

7

A

[ oK l Cancel

En el mend Run Options, debe escribir la siguiente informacion:

Executable: Jusr/lib/mpich-shmem/bin/mpirun
Run Arguments: -np noDenodos rutaDondeSeGeneraElEjecutableDeTuProyecto
Working Directory: rutaDeTuProyecto

|| Run Options

General ~ %] Main Program
~Q Mote: These options override target specific settings.
B =
Version Control Executable: ‘,iusr,liib{mpich-shmem!binfmpirun ‘ ||g|
Run Arguments: ‘-np 4 fhome/manuel/Proyectos/MpiFortran2/src/mpifortran2 |
File Templates Debug Arguments: ‘ |
—J Working Directory: ‘fhomefmanuei{PmyectosﬂpriFm{mnz ‘ |E|
¥ v
Project Documentation - Options
—ﬁ "] Automatically compile before execution
R
File List [] Automatically install before execution
‘f;i | Use kdesu when installing
A
Ftnchek & [%| start in external terminal
|3] ~ Environment Variables
Configure Options " Name Value ‘ ‘ Add / Copy |
- z
B _Ea |
Run Options ‘ Fembie |
@ ‘ Environment |

Make Options [a]
A -

OK l Cancel |

Posteriormente aceptar los cambios dando click en OK.

15
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Escribir tu programa y no olvides incluir la libreria mpif.h, como se muestra en la siguiente figura

mpifortranz.f I

program hello

integer tamanio,rango,error
call MPI_Init(error)

print *,"Heola mundo desde “,rango
call MPI_Finalizel(error)
stop

| end

Antes de compilar por primera vez, debes dar click en las siguientes opciones:

Menu Build -> Install
Menu Build -> Run Automake & Friends
Menu Build -> Run Configure

include "/Jusr/lib/mpich-shmem/include/mpif.h"

call MPI_Comm_Rank(MPI_COMM_WORLD,rango,error)

Para compilar se da click en Menu Build -> Build Project y posteriormente en Menu Build -> Build

Active Target.

Para ejecutar tu programa click en Menu Build -> Execute Program

File Edit ¥iew Project [BUdJ Debug Scripts Bookmarks Tools Settings Window Help

lg I.:i | Eu'fid Pro;:ect
2] Build Active Target

IBE 5D K E| compieEie

Run Configure

Run automake & friends

Inskall

Lt |

|Name | LO-CEi
@ [EHeader files
@ [ESource files

Install (as root user)
Clean Project
Distclean

i Execute Program
Build APl Documentation
Clean API Documentation

F8
F7

Shift+F9

N

LIS

ango) ;

numera del cual gquieres

PEIFd0

INT,1,tag,MPI_COMM WORLD)

-+

a5 - - Bookmarks ) File List |4 File Selector

printf("EL factorial de %d es

Después de ejecutar tu programa debe aparecer una pantalla como la siguiente:

Session Edit View Bookmarks Settings Help

Hola mundo desde
Hola mundo desde
Hola mundo desde
Hola mundo desde
Press Enter to continue!

@ WM

=) | = sbin/sh

16

MPI_Recw(&resultado2,1,MPI_INT,1,MPT_ANY TAG,

%d"” , num, resul
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5. Configurando openMP para Fortran
5.1 Paquetes a instalar

Debe instalar los siguientes paquetes, sélo si no instald los necesarios para usar MPI.

Archive Editar Paquste Configuracién Ayuda

> binutils B 5 .
Recargar Marcar todas las actualizaciones  Aplicar Propiedades Buscar
> aUtomake j‘Todo | ]E\_ Paquete Versidn instalada jL’Jltlma version :Descnpmén |_:
i i L it Sy
> autoconf _ |0 mpich-mpd-bin 1.2.7-8 MPI parallel comnputing sy
> 4 O mpichpython 2.4.11-1ubuntu3 MPl-enhanced Python intsi‘ =
g 1 rripich-shmarm-bin : MP| parallel cormputing s f
> gCC [D mpi-doe 1.2.7-8 Documentation for the M~
[ T vl
» gfortran I - _ _ _ : -
[l | 1+[{MPI parallel computing system implementation, SHMEM version =
> m4 Secciones [ MPICH is a robust and flexible implermentation of the MPI (Message Passing
. | |Interface). MPIis often used with parallel or distributed computing
Estado
> IlthOI R ,\ projects. MPICH is a multi-platform, configurable system (development,
Origen i i .
> konsole g | execution, libraries, etc) for MPI. It can achieve parallelism using
Filtros personalizados | networked machines or using multitasking on a single machine, =
> kdevelop e |
BAEISEERED bUSqUEda I Thie seneri el suith abh eh s rt_suhich riune in charnd maraane

38 paquetes listados, 1295 instalados, 0 rotos. 0 para instalar/actuslizar, 0 para eliminar

5.2 Creando un programa en Kdevelop

Menu Project -> New Project. Elegir de tipo Fortran y escribir el nombre del proyecto a crear y elegir
la ubicacién del mismo.

General

All Projects | Favorites

[EdFortran

EH | E1E2)

["] Show all project templates

~Properties

Application name: ImiPmyecto| |

Location: l[home/manuelfProy ectos/ | |E|

Final location: [home/manuel/Proyectos/miProyecto

| Cancel

17



5. Configurando openMP para Fortran Tec. Manuel Antonio Ortiz Montalvo

Para configurar openMP, debe dar click en Menu Project -> Project Options -> Configure Options, y en
la pestafia general debe configurar la siguiente opcidén:

Linker Flags (LDFLAGS): -fopenmp

@ |«| configure Options

General Configuration: [debug v|
pe [General | € [ v+ | Eommn |
S

Version Control Configure arguments:

[——enable—debug:full |

File Templates Build directory {must be different for every different configuration):

‘;J [debug 1 Ij
Project D;u‘mentation “tap solice difectony -

abifes C/C++ preprocessor flags (CPPFLAGS):
File List AR &

=1 | |
’,__.LJ Linker flags (LDFLAGS):

C++ Support

| ‘—fopenmp |
ettt
Configure Options |Name value || addrcopy |

s Cosn
Run Options |W|
Make Options
T E=
Formatting

I Environment I

i

Y en la pestana Fortran, debe configurar las siguientes opciones
Fortran Compiler: GNU Fortran 77 Compiler
Compiler Command (f77): gfortran
Compiler Flags (FFLAGS): -fopenmp -pg

It

Configure Options

General Configuration: [defau!t |-|-|
<= General | C | ct++ |Eortran |
S

Version Control

File Templates Compiler command (F77): |gfort|:-m |

[

LIl
Project Documentation
@
P>
File List

Fortran compiler: |GNU Fortran 77 Compiler |v|

Compiler flags (FFLAGS): [—fopenmp -pg | |:]

Configure Options

Y

Run Options

Make Options o

b

1

o
(.

BOK || Cancel

Posteriormente aceptar los cambios dando click en OK.
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Escribir el siguiente cédigo de ejemplo, para demostrar como funciona openMP. Nétese que debe
incluir la libreria omp_lib.h, como se muestra en la siguiente figura.

openmpfartran.f |

= program hello

include "omp 1lib.h"

integer hile,noHilos,OMP_GET NUM THREADS,OMP GET THREAD NUM
call OMP SET NUM THREADS(3)

1 SOMP PARALLEL P
hilo=0MP GET THREAD MUM()
noHilos=0MP GET NUM THREADS()

print *, 'Hile ', hile,' Be ',noHiles
- :

VATE BT la) SHARED (nakillos)

stop
end

Antes de compilar por primera vez, debes dar click en las siguientes opciones:
Menu Build -> Install
Menu Build -> Run Automake & Friends
Menu Build -> Run Configure

Para compilar se da click en Menu Build -> Build Project y posteriormente en Menu Build -> Build
Active Target.

Para ejecutar tu programa click en Menu Build -> Execute Program

File Edit View Project -Blgj,!{} Debug Scripts Bookmarks Tools Settings Window Help

g B I._i |1 ﬁu%id Pro;iect F8 L @ ,E m 0
N i .1 Build Active Target F7 e v
BB T & | B compilemie
g I Hiatie |El Run Configure )
% ® [ Header files Run automake & friends fngon ;
¥ | @ |g3 Source files Install
% Install {(as root user) numero del cual guieres
™ Clean Project
I Distclean L s
; [NT,1,tag,MPL_COMM WORLD)
fies i Execute Program Shift+F9
ik Build APl Documentation H)
g Clean API Documentation
£
g MPI_Recv(&resultado2,1,MPI_INT,1,MPI_ANY TAG,
@
3 4 . printf("El factorial de %d es %d",num,resul
n ¥

Después de ejecutar tu programa debe aparecer una pantalla como la siguiente:
session Edit View Bookmarks Settings Help

Hilo 1 De 3 Lf}
Hilo 2 De 3
Hilo 8 De B

Press Enter to continue!

I =8

(= | pingsh |
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5.3 Compilando y ejecutando desde la linea de comandos

Para compilar desde la linea de comandos, primero debes ubicarte en la carpeta que contiene el
codigo fuente.
Session Edit Wiew Bookmarks Settings Help

manuel@manuel-laptop:~% cd Proyectos/openMpFortran/src/ =]
manuel@manuel-laptop:~/Proyectos/opentpFortran/srcd I
e
=
i1
|==|| s shell | i Shell No.2 | @ Shell No.3 | ==
Posteriormente ejecutar el siguiente comando para realizar la compilacidon
gfortran -pg -fopenmp -o programakEjecutable codigoFuente.f
Donde:
-pg Activa la opcion de generar el Profile
-fopenmp Activa la opcion de crear ambiente paralelo
-0 Genera el archivo objeto
programakEjecutable Nombre del archivo ejecutable, que generard la compilacion
codigoFuente.c Nombre de tu archivo fuente
A continuacion se muestra un ejemplo:
Session Edit View Bookmarks Settings Help
manuel@manuel-laptop:~/Proyectos/openpFortran/src$ gfortran -fopenmp -ol|
prusba openmpfortranm.f
manuel@manuel-laptop:~/Proyectos/openMpFortran/srcs I
[
Ll
(=3
=~ | Wishell | e shell No. 2 | & Shell No. 3 ‘ (A

Y ya para ejecutar tu programa, sdlo debes escribir el nombre de tu ejecutable que se acaba de
generar, antecedido por los signos “./ “, y tu programa debe empezar a ejecutarse, como muestra el
siguiente ejemplo:

Session Edit View Bookmarks Seitings Help

manuel@manuel - laptop:~/Proyectos/openMpFortran/srcs ./prueba [

Hilo 1 De 3

Hilao 2 De 3

Hilo B De 3 [

manuel@manuel - laptop:~/Proyectos/openMpFortran/srcs I (=]
[

|| wshell | @ Shell No.2 | [ Shell No. 3 =
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6. Creando el profile para Fortran

Si se desea hacer un analisis de la ejecucidon del cédigo, los tiempos que demord la ejecucion de cada
método, y las veces que se llamo cada uno, entre mucha otra informacién, se puede crear el profile.

Para crearlo, primeramente el programa se tiene que compilar activando la bandera pg:

gfortran -pg -openmp -o programa archivoFuente.f

Session  Edit View Bookmarks Settings Help

manuel@manuel-laptop:~/Proyectos/openMpFartran/src$ gfortran -pg - fopenm |«
p -o prueba openmpfortran.f
manuel@manuel-laptop:~/Proyectos/openMpFortran/srcs I

Gl ]

| mmshell | mshell No.2 | M shell No.3 |

Si compild correctamente, se tuvo que generar un archivo llamado gmon.out en la carpeta de tu
cadigo fuente.

Posteriormente, se crea tu archivo profile, de la siguiente manera:
gprof programa gmon.out > archivo.txt

Donde:
programa:  Es el nombre del ejecutable que se generd durante la compilacion
gmon.out Archivo que se generd durante la compilacion con la bandera pg
archivo.txt ~ Nombre del archivo que generard con la informacion del profile

Session Edit View Bookmarks Settings Help

manuel@manuel-laptop:~/Proyectos/openMpFortran/src$ gprof prueba gmon.ou [+]
t = profile.txt
manuel@manuel-laptop:~/Proyectos/openMpFortran/src$ I

]
=]

(|

/| (@ Shell | mShell No.2 | @ Shell No. 3 | ]

Para visualizar el archivo que generd, sdlo tienes que escribir el comando:
edit nombreArchivo

Donde:

nombreArchivo: Es el nombre del archivo a visualizar, que es el que generamos con el
comando gprof
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A continuacidn se muestra un ejemplo de la ejecucién del comando, y el resultado del mismo.

Session Edit View Bookmarks Seftings Help

manuel@manuel-laptop:~/Proyectos/openMpFortran/src$ edit profile.txtl[:j

]
=
- |

_|| & shell No. 3 |

Session Edit View Boockmarks Settings Help

]Elat profile: A

Each sample counts as 0.01 seconds.
no time accumulated

% cumulative self self total
time seconds seconds calls Ts/call Ts/call name
0.08 8.00 8.e8 1 B.08 0.08 MAIN
% the percentage of the total rumning time of the
time program wsed by this function.

cumulative a running sum of the number of seconds accounted
seconds for by this fumction and those listed above 1it.

self the number of seconds accounted for by this

seconds function alone. This is the major sert for this
listing.

calls the number of times this funmction was imvoked, if

this function is profiled, else blank.

self the average number of milliseconds spent in this
ms/call function per call, if this function is profiled,
else blank.
total the awverage number of milliseconds spent in this
ms/call function and its descendents per call, if this
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